The Witcher Enhanced Edition and The Witcher 2 Assassins of
Games

The Witcher: Enhanced Edition and The Witcher 2: Assassins of Kings for Mac will soon support M1 and M2 processors, but there’s bad news

Developer of the Polish studio CD Projekt RED warned about the upcoming change in the system requirements of the first two parts of its role-playing game series The Witcher (“The Witcher”) for Mac computers.

    Image source: Steam (BUTCHER)

Image source: Steam (BUTCHER)

It has been announced that The Witcher: Enhanced Edition and The Witcher 2: Assassins of Kings will soon receive support for Apple Silicon M1, M2 processors and macOS Ventura (13.0).

In this regard, support for OS X 10.7.5, OS

    Image source: CD Projekt RED

Image source: CD Projekt RED

CDPR justified its decision by saying that support for Apple Silicon processors requires technology, JIT-compatible memory management and the operation of Apple’s game controller toolkit, which require at least macOS 11.0.

The adjustments will come into force in one month, mid-November: “It is important for us that the players have time to prepare for the changes. Therefore, we will notify you 30 days before we end support for these operating systems.”.

    Image source: Steam (Reaper)

Image source: Steam (Reaper)

To continue playing on macOS versions before 11.0, you don’t need to update the game: on Steam and GOG you need to turn off automatic updates, but on the App Store you don’t need to do anything.

CD Projekt RED also warns that if you reinstall a deleted game, only the latest version will be available on all platforms, but GOG will have the option to revert to a previous build.

About the author

Alan Foster

Alan Foster covers computers and games and all the news in the gaming industry.

Add Comment

Click here to post a comment